木子屋 Dnawo's BLOG

2008-04 归档

共 60 篇

一次精简JS代码过程

实现功能:页面上用三个按钮分别控制三个div的显示/隐藏。 思路一:分别写三个函数来实现。 思路二:整合成一个函数来实现。 思路三:再精简。

Dvbbs 8.2.0修改:管理员放权,楼主可管理跟贴

通常在论坛中只有版主以上级别的人才拥有删除单贴的权限,个人觉得这不够人性化,楼主发表了一个话题,他应该有权决定谁可以参与回复,或者说是他可以决定哪些回复是有意义的并留下来,删除那些无意义的回复。如果管理员可以适当放权,让楼主可管理跟贴,个人觉得这不仅有助于提高论坛贴子的质量,并且还能给论坛管理员减少不少的工作量,可谓一举多得。下边我们就来修改Dvbbs Version 8.2.0实现上述功能。 1.模板修改 以管理员身份登录后台,依次打开"风格界面模板总管理→分页面模板(page_dispbbs)→界面风格→template.html(0)",搜索"{$canedit.end}",并在其后增加下边代码:…

已经CheckUser了为什么还出错?

在需授权才能访问的页面中一般都有相关的程序做身份验证,在ASP中通常是将身份验证的程序单独放在一个文件中,然后在需授权的页面顶部调用这个文件进行验证身份,身份验证失败后就跳转到一指定的页面中(如登录页)。 今天在一ASP.NET站上也有类似的流程,但却总出错,研究了下,下边是简化了的代码: checkuser.aspx: Manage.aspx: 奇怪的是不仅没有跳转到login.aspx页,反而是页面发生了错误"未将对象引用设置到对象的实例"!原因是Session("username")为空值,使用ToString()导致出错!不是放在最前边了,怎么没像ASP那样发生作用呢?其实原因也很简单:ASP.NET和ASP有个很大不同的地方,就是有了Page_Load等事件,Page_Load在页面一打开就触发了,它里面的代码比页面中其他代码都先执行!所以在上边的例子中应是先执行了Page_Load,再执行checkuser(),这就不难解释为什么没有跳转反而出错了。知道了原因稍加修改即可:…

让ASP也支持动态include文件

一直觉得ASP的include非常的别扭,一是它不能放在""之间,感觉很独特,很格格不入,二是它不能像PHP的include那样可以动态的随意包含文件!以前也有人试图解决过这个问题,但总是不尽完美,今天在pscode.com又看到有人写了个类来解决这个问题,可以说它是在我所见过的解决方法中最好的了。由于原类中存在一些不足,我稍做了修改,下边为修改后的代码: 修改说明: 1.原类convert2code函数中使用"|"做为分隔符,一旦包含文件中存在Response.Write("mzwu|com")类似的语句将导致出错,用"|"做为分隔符更是大大提高了出错的机率!修改后增加了一个变量str_separator,可自由定义分隔符,降低出错率。…

个人从事设计行业40句观感

做一个总结,把自己这些年的从业经历和观感罗列一下,某些话可能触及到个人神经,但它们没有恶意。 设计师喜欢把世界想象得很美好,社会很和谐,但是这些都只是愿望,真实情况是,设计师在个人成长和职业发展中总会遇到很多客观问题,而面对问题的时候,个人的IQ和EQ就变得很重要。 和大家共享交流一些我的看法,有助于以更平和的心态继续提高自己。 关于公司: 1.好的公司只有那几个,剩下的大多数都是不怎么样的,但好在有一些不错的人让你支持下去; 2.在中国当今社会中,你能够从公司的设计团队中找到真正的朋友; 3.公司的性质取决于客户的性质,客户的性质取决于市场的需求,因此设计师必须先了解市场的需求; 4.公司中别有用心的人很多,当有人质疑你能力的时候,你也应该有能力让他闭嘴;…

两步修改Windows 2000/XP远程管理默认端口

自Windows 2000开始,微软就提供一项终端服务(Terminal Server)这项服务可以将远程的桌面传递到本地。通过该服务,可视化的远程管理可以非常方便的实现。继Windows 2000之后,Windows XP也提供这项服务。在Windows XP 中的Terminal Server Client程序比Windows 2000中的那个有了进一步的发展,许多功能都强大了许多。 Windows XP 中的Terminal Server Client程序主要的新特性有: 1)可以将目标机器上的声音带回本机; 2)支持真彩色并可以全屏使用; 3)而且不用安装,只需两个文件 mstsc.exe 和 mstscax.dll 就可以使用了,非常方便;…

JSON简介

JSON(JavaScript Object Notation) 是一种轻量级的数据交换格式。易于人阅读和编写。同时也易于机器解析和生成。它基于JavaScript Programming Language, Standard ECMA-262 3rd Edition - December 1999的一个子集。 JSON采用完全独立于语言的文本格式,但是也使用了类似于C语言家族的习惯(包括C, C++, C#, Java, JavaScript, Perl, Python等)。这些特性使JSON成为理想的数据交换语言。 JSON建构于两种结构: 1). "名称/值"对的集合(A collection of name/value pairs)。不同的语言中,它被理解为对象(object),纪录(record),结构(struct),字典(dictionary),哈希表(hash table),有键列表(keyed list),或者关联数组 (associative array)。…

更改 SQL Server 2000 端口号

如果要更改SQL Server端口,我们可以通过"服务器网络实用工具"和"客户端网络实用工具"来设定,具体方法是: 分别打开"服务器网络实用工具"和"客户端网络实用工具",更改"常规"→"启用的协议"→"Tcp/Ip"→"属性"中的端口,假设为1455 然后使用"telnet sql服务器地址 1455"看看能不能telnet通,如果可以就代表更改成功了! 以往的B/S应用程序中数据库的连接一般都没有带端口号,所以比较好写,但是现在更改了端口号,那应该怎么写连接语句呢?下面的数据库连接语句就是更改端口后的形式: 输出结果为: uid=sa;password=sa;database=union_5k3g;server=192.168.0.1,1455…

SQL Server 日志文件过大预防及解决方法

事务日志文件(Transaction Log File)是用来记录数据库更新情况的文件,扩展名为LDF。 在 SQL Server 2000 中,如果设置了自动增长功能,事务日志文件将会自动扩展。一般情况下,在能够容纳两次事务日志截断之间发生的最大数量的事务时,事务日志的大小是稳定的,事务日志截断由检查点或者事务日志备份触发。然而,在某些情况下,事务日志可能会变得非常大,以致用尽空间或变满。通常,在事务日志文件占尽可用磁盘空间且不能再扩展时,您将收到如下错误消息: Error:9002, Severity:17, State:2 The log file for database ’%.*ls’ is full.…