在建立与服务器的连接时出错。在连接到 SQL Server 2005 时,在默认的设置下 SQL Server 不允许进行远程连接可能会导致此失败。 (provider: 命名管道提供程序, error: 40 - 无法打开到 SQL Server 的连接)
改用别名进行连接错误发生了变化:
在建立与服务器的连接时出错。在连接到 SQL Server 2005 时,在默认的设置下 SQL Server 不允许进行远程连接可能会导致此失败。 (provider: TCP提供程序, error: 0 – 由于目标机器积极拒绝,无法连接)
错误的原因是SQL Server2000数据库所在服务器没有安装SQL SERVER 2000 SP4升级包导致的,安装重启下就好了。
查看SQL SERVER 2000版本的办法:打开服务器属性,在常规选项卡中查看"产品版本"或是在查询分析器中执行查询"print @@version"。
SP4升级包下载地址:http://www.os8.cn/showdown.asp?soft_id=1287
评论(0)
暂无评论。