木子屋 Dnawo's BLOG

VS2008使用Internet方式连接VSS2005

👤 dnawo 📅 2011-04-16 👁 6632 👍 0 💬 0 🔄 本站原创
一、服务端设置

①.创建数据库文件夹E:\vss,设置共享,并给Everyone分配所有权限[1]:
图片

②.记住E:\vss的网络路径,一般为"\\计算机名\vss",例如\\kwww-9e22df5b3c\vss;

③.打开Microsoft Visual SourceSafe Administration,创建新数据库,注意路径必须填写网络路径[2]:
图片

④.设置可以Internet访问数据库,依次打开菜单"Server→Configure",钩选"Enable SourceSafe Internet for this computer"和"Enable SourceSafe Internet for this database",将会在IIS建立一个虚拟目录SourceSafe[3]:
图片

⑤.创建一个Windows用户,例如VssUser,打开E:\vss安全选项卡,给VssUser分配所有权限[4][5];

⑥.在Microsoft Visual SourceSafe Administration创建一个用户,用户名和密码都和windows用户VssUser相同[6];

二、客户端设置

①.打开VS2008,打开"选项"对话框,源代码管理插件选择"Microsoft Visual SourceSafe(Internet)":
图片

②.打开"插件设置",点击高级按钮,去掉"Always use SSL to connect to the server"前的钩:
图片

③.使用VSS2005管理源代码即可:
图片

图片

图片

图片

图片

图片

图片

图片

三、其他说明

[1].必须要给Everyone分配所有共享权限,否则VSS创建新数据库会失败:
图片

[2].VSS数据库路径必须为网络路径,否则不能设置Internet访问数据库:
图片

[3].服务器必需安装.NET2.0,因为VSS2005是通过WEB Services来提供服务的,http://url/SourceSafe/VssService.asmx

[4].必须要给VssUser分配E:\vss读取权限,否则VS2008连接失败,提示"The specified share path cannot be accessed by the SourceSafe Web Service":
图片

[5].必须要给VssUser分配E:\vss写入权限,否则VS2008连接失败,提示"VSS Web Service could not open the database":
图片

[6].VSS2005必须要创建同名用户VssUser,否则VS2008连接失败,提示"Visual SourceSafe Internet plug-in could not connect to the specified database":
图片

[7].使用中发现在连接VSS2005或是文件签出时经常无缘无故提示"未指定错误":
图片

评论(0)

暂无评论。

计算题
评论需审核通过后显示
← 上一篇 清除访问局域网其他机子时记住的用户名和密码 下一篇 → 关于图片的预加载,你所不知道的