木子屋 Dnawo's BLOG

分类:服务器

共 348 篇

Service 'VisualSVN Server' failed to start

今天用TortoiseSVN登录服务器时提示服务器找不到,后来发现是服务器上的"VisualSVN Server"服务停止了,尝试手动启动服务总是失败,提示: VisualSVN Server 服务因 1 (0x1) 服务性错误而停止。 没办法,只好尝试重装VisualSVN,但也是失败,还是服务无法启动: 最终解决方法:给Users用户组分配C盘读取权限即可。

http错误日志的Hostname解决方法

将一个站点移到新服务器后,新服务器上出现了很多http错误日志(C:\WINDOWS\system32\LogFiles\HTTPERR),内容如下: #Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename 2011-04-03 02:48:16 212.151.224.216 26798 61.191.61.146 80 HTTP/1.1 GET /portal/m/c5/3.ashx?r=1 400 - Hostname - 2011-04-03 02:48:17 202.91.18.201 1450 61.191.61.146 80 HTTP/1.1 GET /portal/m/c5/3.ashx?r=1 400 - Hostname -…

获取ISAPI_Rewrite重写前的URL

为站点编写的ISAPI_Rewrite规则如下: 当访问http://localhost/10000时,ISAPI_Rewrite会将其重写到真实地址http://localhost/User/Default.aspx?id=10000中,怎么得到重写前的地址呢?使用Request.Url,得到的是真实地址,百度后知道ISAPI_Rewrite会添加一个HTTP头X-Rewrite-URL: 获取ISAPI_Rewrite重写前的URL代码:

SQL Server2005为登录名分配数据库权限失败:创建对于用户"user01"失败

下午在SQL Server2005上新建了一个登录名user01,但在给他分配数据库权限(DataCenter)时总是失败,提示:创建对于用户"user01"失败。 找了很久才发现原因,但在说明原因之前我先说明一个现象:SQL Server2005登录名和数据库用户是两个不同的概念,在给登录名分配数据库权限时都会为数据库新建一个用户,并将他们关联,由于新建用户名称和登录名默认是相同的,不需要去修改,所有我们平时可能不会注意到这个。在删除登录名时,数据库中同名用户并不会一块删除,这在删除登录名时有说明。 好了,现在可以说明原因了:由于先前新建过登录名user01并给DataCenter分配过权限,后来删除了登录名user01,注意仅仅是删除了登录名,数据库中同名用户没有删除,今天再创建登录名user01并分配数据库权限时,由于数据库已经存在用户user01,所以就出错了。解决方法有两种:一是删除数据库用户user01,二是修改默认的新建的数据库用户名,再分配数据库权限就可以成功了。…

H3C ICG 1000路由器WEB管理80端口不能修改

以前使用TL-WR340G路由器,不管是在内网还是在外网登录管理页面,它们使用同一个端口80,并且是可以修改的: 今天看H3C ICG 1000路由器,发现它内网和外网登录管理页面的端口是分开的,外网登录端口可以修改,而内网固定使用80端口不能修改,如果将外网登录端口设置为80,虽然能设置成功,但不能使用它来登录。 在虚拟服务器等服务中也都无法使用80端口

H3C ICG 1000路由器IP和MAC绑定示例

打开H3C ICG 1000系统管理界面,在左边菜单中依次选择"安全专区→ARP防攻击",切换到"IP/MAC表"选项卡,在IP/MAC绑定表中即可绑定IP和MAC。

弃用数据库自增ID的解决方法

解决思路 1).定义一张表,专门用来存放存所有需要唯一ID的表名称以及该表当前所使用到的ID值。 2).写一个存储过程,专门用来在上一步的表中取ID值。 这个思路非常简单,我不作解释了,直接来看看我的实现方法: 第一步:创建表 第二步:创建存储过程来取自增ID 作者原文 1).弃用数据库自增ID,曝光一下我自己用到的解决方法 http://www.cnblogs.com/repository/archive/2011/01/17/1937265.html 2).弃用数据库自增ID,曝光一下我自己用到的解决方法之---终结篇 http://www.cnblogs.com/repository/archive/2011/01/20/1939450.html

ISAPI_Rewrite使用示例

第一步:安装ISAPI_Rewrite 下载ISAPI_Rewrite,然后一路next安装,待安装完成后运行"ISAPI_Rewrite Configuration Utility"注册: 执行iisreset /restart生效。 第二步:为站点编写URL重定向规则 哪个站点需要URL重定向,只要在这个站点根目录下放一个httpd.ini文件并编写相应的规则即可,下边是一个简单的httpd.ini示例: 第三步:测试效果 View.asp: 官方站点:http://www.helicontech.com/isapi_rewrite/

FTP连接提示:数据 Socket 错误: 连接被拒

FTP服务器配置为Windows Server 2003 Enterprise Edition SP2 + Serv-U 6.4.0.2,FTP端口号为3321。本来都能正常连接使用,自从在TCP/IP筛选中加了端口限制后就出问题了: 连接信息如下: WinSock 2.0 -- OpenSSL 0.9.8g 19 Oct 2007 正在连接到 192.168.203.128 -> IP=192.168.203.128 PORT=3321 已连接到 192.168.203.128 220 Serv-U FTP Server v6.4 for WinSock ready... USER User…