木子屋 Dnawo's BLOG

分类:服务器

共 348 篇

将设置密码的access数据导入到mssql

上边是mssql2000导入数据向导的选择数据源界面,若access设置有密码,很多人在这边都会为难:用户名是什么?在给access设置密码时并没有提示用户名相关信息,便开始百度怎么获取用户名,最终都以失败告终。正确的做法是:界面中用户名、密码留空,打开高级设置界面,在"Jet OLEDB:Database Password"一项设置好密码,便可以导入了。

SQL Server2000 表关系

可以在数据库关系图中的表间创建关系以显示某个表中的列如何链接到另一表中的列。 在关系数据库中,关系能防止冗余的数据。例如,如果正在设计一个数据库来跟踪有关书的信息,而每本书的信息(如书名、出版日期和出版商)都保存在一个名为 titles 的表中。同时还有一些想保存的有关出版商的信息,例如出版商的电话号码、地址和邮政编码。如果将所有这些信息都保存在 titles 表中,则对于某个出版商出版的每本书,出版商的电话号码将是重复的。 一个更好的解决方案是,单独在一个名为 publishers 的表中只保存一次出版商信息。然后在 titles 表中设置指针,以引用 publishers 表中的项。 若要确保数据同步,可以在 titles 表和 publishers 表之间强制引用完整性。引用完整性关系能确保某个表中的信息与另一个表中的信息相匹配。例如,titles 表中的每个书名必须和 publishers 表的特定出版商相关联。不能在数据库中添加数据库中不存在的出版商的书名。…

T-SQL常见编号查询

1. 构造IN进行编号查询 a. 要查询的字段类型是数字型 b. 要查询的字段类型是字符型 2. 使用LIKE或者PATINDEX进行编号查询 3. 编号查询中常见的错误 a. 最容易犯的错误:表达式充当表达式列表 b. 生成动态Transact-SQL语句时忽略了数据类型 c. 忽略了比较的精确性问题

VSS2005找回文件历史版本内容

1.找回未删除的文件历史版本 1).右键点击文件,选择"Show History...": 2).填写查询版本的条件。From表示开始时间,To表示结束时间,User表示用户: 3).下图列出了指定条件范围内的所有版本: 选中某一版本,点击右边的"View"按钮查看文件内容或是点击"Get"按钮获取文件。 2.找回已删除的文件历史版本 1).右键点击已删除文件所在文件夹,选择"Show History...": 2).填写查询版本的条件: 3).下图列出了指定条件范围内的所有版本: 这边不能再用"View"按钮查看文件内容,而是选中文件,然后点击"Get"按钮获取。 所以:一定要养成每次签出修改后马上签入的习惯,如果多次修改再签入就无法正确找回历史版本内容了。…

VSS2005添加文件夹的两种方法

VSS2005中可以使用"Add Files..."将本地文件添加到项目中,但VSS2005没有提供将文件夹添加到项目的方法,如要添加文件夹可使用下边两种方法: a. 在资源管理器中将文件和文件夹拖到VSS2005项目中; b. 在VS2008中将项目绑定到VSS2005项目再签入; 建议:VS2008创建的项目最好使用方法b,如果采用方法a会导致一些不必要的文件或文件夹(诸如csproj、sln文件和bin、obj文件夹等)也签到VSS中。

IIS网站服务器性能优化指南

Windows Server自带的互联网信息服务器(Internet Information Server,IIS)是架设网站服务器的常用工具,它是一个既简单而又麻烦的东西,新手都可以使用IIS架设一个像模像样的Web站点来,但配置、优化IIS的性能,使得网站访问性能达到最优状态却不是一件简单的事情,这里我就介绍一下如何一步一步的优化你的IIS服务器。 服务器端环境,我们以Windows Server 2003的IIS6.0为例,客户端环境为Mozilla Firefox 3.0,同时安装Yahoo的YSlow扩展。 YSlow是Yahoo开发者团队发布的一款基于Firebug的插件。用于分析网页,并根据一些高性能网站的规则进行相应的评级打分,对于网页性能优化有很好的帮助作用,告诉你那些部分影响了你的网页速度,并告诉你如何基于某些规则而进行优化。我们对于IIS的优化策略就是基于YSlow的。…

安全移动站点上图片/下载资源到另一台服务器

例如我们的木子屋站点,原先所有图片资源都是放在根目录下的pic文件夹中,但由于图片下载太占资源,所以打算将图片资源全部移到另一台服务器上,问题是如何能做到安全移动,保证用原先地址仍能正常访问呢? 开始想到的是使用URL重写,将http://www.mzwu.com/pic/***类似的地址转到http://pic.mzwu.com/***,后来发现不用这么麻烦,使用IIS的重定向到URL功能即可完成,只需在IIS上新建一个虚拟目录pic,并将其重定向到http://pic.mzwu.com/即可: 尝试访问下面地址: 将自动跳转至:

Serv-U使用虚拟路径改善用户对多个目录的访问方式

假如有一个用户主目录为G:\User,现在想让用户还可访问G:\test1和G:\test2,Serv-U允许我们给一个用户设置多个访问目录: 使用FlashFXP登录看下,出问题了,只能看到G:\User下的内容,G:\test1和G:\test2都找不到,原因是Serv-U设置将用户锁定于主目录下,回到Serv-U去掉将用户锁定于主目录前的钩,再登录看下,默认打开的还是主目录的内容,双击一下上层目录,现在可以看到三个目录了:)问题似乎是解决了,只是用户操作起来有些不便(每次都得转到上层目录中才可访问G:\test1或G:\test2),能不能在用户登录时看到的就是全部可访问的目录列表呢?该是虚拟路径出场了,打开"域→设置→虚拟路径",点击添加按钮: 第一步:输入被映射到虚拟路径的物理路径,G:\test1…

用触发器生成SQL Server2000数据表的操作日志

有时,我们想知道登录到数据库的用户做了什么,于是,记录用户执行的SQL语句就非常有必要,这将是重要的参考依据。我们先建一张日志表(DBLoger)用于保存用户执行的SQL语句: 接着再建一个触发器,在用户对表进行增/删/改时触发,将执行的SQL语句记录到日志表中: 说明:由于dbcc inputbuffer的EventInfo最多只能保存255个字符,所以一旦执行的SQL过长,日志表中将无法看到完整的SQL语句! 参考:http://topic.csdn.net/t/20061130/11/5196444.html