木子屋 Dnawo's BLOG

分类:服务器

共 348 篇

HTTP 403.6 - 禁止访问:IP 地址被拒绝

症状说明: IIS中配置站点IP地址为:192.168.0.146,但访问时却显示" HTTP 错误 403.6 - 禁止访问:客户端的 IP 地址被拒绝",将站点IP改为:127.0.0.1却可以正常访问! 原因分析: IIS提供了IP限制的机制,你可以通过配置来限制某些IP不能访问站点,或者限制仅仅只有某些IP可以访问站点,而如果客户端在被你阻止的IP范围内,或者不在你允许的范围内,则会出现错误提示。 解决方法: 进入IIS的属性->安全性->IP地址及域名限制。发现配置如下: 改为授权访问,确定后再访问就没问题了:

访问本地站点出错:Server Application Error

访问本地动态页面全都出错,提示: Server Application Error The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance. 网上搜索相关资料说是由于IWAM账号的密码错误造成的,修改方法如下: 1.打开CMD.EXE,输入"cd C:\Inetpub\AdminScripts"…

Windows Server 2003中IIS 6.0配置

Windows Server 2003粉墨登场,很多赶时髦的用户已经早就试用了,尽管Win 2003号称安全性有很大突破,但其默认支持.net架构,抛弃使用了很久的大众化的Asp的路线而饱受质疑,需要我们手动去配置: 1、启用Asp支持。Windows Server 2003中IIS 6默认是不支持ASP的,需手工开启。进入IIS(Internet 服务器) → Web服务扩展 → Active Server Pages → 允许 2、启用包含文件。IIS(Internet 服务器) → Web服务扩展 → 在服务端的包含文件 → 允许 3、启用父路径支持。IIS(Internet 服务器) → 网站 → 主目录 → 配置 → 选项 → 启用父路径…

50元打造双网卡负载均衡服务器

  前言:市面上现在天生支持绑定功能的网卡不多,而且多是出身名门的高档服务器网卡,身价不菲,设置过程也比较专业,使用和维护都不简便。难道我等平头百姓,攥着几十元的廉价8139的兄弟们就无缘领略双网卡绑定的快感了吗?非也,今天我就教大家一招,只需一款小小的软件,就可以用普通的8139之类的网卡体验一把双网卡绑定的愉悦,这个软件就叫做“NICExpress”,可能行家们已经捂着嘴乐了,呵呵,笔者的出发点是给菜鸟兄弟们排难解惑,穷办法自娱自乐,说得过火的地方,大家不要见笑,DIY的乐趣就在于此啊。   朋友或许会问了,为什么要用双网卡呢?用双网卡有什么好处?所谓双网卡,就是通过软件将双网卡绑定为一个IP地址,这个技术对于许多朋友来说并不陌生,许多高档服务器网卡(例如intel8255x系列、3COM服务器网卡等)都具有多网卡绑定功能,可以通过软硬件设置将两块或者多块网卡绑定在同一个IP地址上,使用起来就好象在使用一块网卡。   多网卡绑定的优点不少,首先,可以增大带宽,假如一个网卡的带宽是100M,理论上两块网卡就是200M,三块就是300M,当然实际上的效果是不会是这样简单的增加的,不过经实际测试使用多个网卡对于增加带宽,保持带宽的稳定性肯定是有裨益的,如果交换机等相关条件不错的话,这个效果还是很能令人满意;其次,可以形成网卡冗余阵列、分担负载,双网卡被绑定成“一块网卡”之后,同步一起工作,对服务器的访问流量被均衡分担到两块网卡上,这样每块网卡的负载压力就小多了,抗并发访问的能力提高,保证了服务器访问的稳定和畅快,当其中一块发生故障的时候,另一块立刻接管全部负载,过程是无缝的,服务不会中断,直到维修人员到来。…

Dvbbs在服务器上的安全配置

N多站长都在说自己的网站被挂马,或者被黑,好多站长估计都经历过论坛程序文件被人修改吧? 告诉大家如何在服务器上配置安全的动网论坛(如果是租的服务器,请将此帖发给空间商,让他们帮他配置一下) 先来看一张图 在文件夹上点右键,选“属性”,在“安全”标签上,可以得到这样的图 先说第一部分:组或者用户名称 服务器上每一个分区的属性中,只允许包含以下两个用户组的“完全控制”权 Administrators SYSTEM 如果你的分区中多了其他用户组,如Users、Everyone等用户组权限,呵呵,被黑就太正常了 然后看论坛程序的安装目录,如D:\bbs目录,此目录就要多给一个用户组权限,那就是“Internet 来宾账户”。…

IIS中实现http自动转换到https

若IIS中某个网站使用了SSL连接,用户访问的时候就会显示403.4错误,而不会自动转换到https的连接上。其实这个功能实现起来是非常简单的,只要在403.4的错误页面加上几句Javascript代码就能搞定了。实现简单,但是却非常的实用,特别是对于那些客户电脑知识缺乏的,出现了这样的错误提示,肯定找不到方向了,呵呵。 修改文件:C:\WINDOWS\Help\iisHelp\common\403-4.htm为以下内容

UrlRewrite(地址变换)技术在IIS 5.0/ASP平台上面的应用

在聊这个技术问题前,我不由得想起一个可笑的故事。NetCraft曾经做了一个测评,这个测评根据比较大量网站页面的扩展名是ASP.NET的还是JSP/Servlet的,得到了一个结论,现在ASP.NET的应用超过了JSP/Servlet。 这个测评引发了大量的讨论,很多用JSP的技术人员嘲笑这个测评。因为这个测评的结论忽略了一个很大的问题。那就是,JSP开发的网站的页面,一定是.jsp么? 答案当然是否定的。特别是mvc结构的网站常常都是没有.jsp扩展名的,这是一个惯例了。如果不是为了避免混淆,我们甚至可以让JSP的引擎来解析扩展名为aspx的jsp程序,或者让ASP.NET的引擎来解析扩展名为jsp的ASP.NET程序。唯一需要做的就是在服务器的管理工具上面做一些选择,或者修改配置文件等等。…

妙用SSL给IIS加把锁

由于NT系统的易维护性,越来越多的中小企业在自己的网站上和内部办公管理系统上采用它,而且很多都是用默认的IIS来做WEB服务器使用。当然不能否认近来威胁NT系统的几个漏洞都是由于IIS配置不当造成的,而且可以预见,未来IIS还会被发现很多新的漏洞和安全问题,但只要我们做好合理的安全配置,还是可以避免很多安全隐患的。本文并没有系统的去讲如何全面安全的配置IIS,我只是从利用SSL加密HTTP通道来讲如果加强IIS安全的。 一、建立SSL安全机制 IIS的身份认证除了匿名访问、基本验证和Windows NT请求/响应方式外,还有一种安全性更高的认证,就是通过SSL(Security Socket Layer)安全机制使用数字证书。SSL(加密套接字协议层)位于HTTP层和TCP层之间,建立用户与服务器之间的加密通信,确保所传递信息的安全性。SSL是工作在公共密钥和私人密钥基础上的,任何用户都可以获得公共密钥来加密数据,但解密数据必须要通过相应的私人密钥。使用SSL安全机制时,首先客户端与服务器建立连接,服务器把它的数字证书与公共密钥一并发送给客户端,客户端随机生成会话密钥,用从服务器得到的公共密钥对会话密钥进行加密,并把会话密钥在网络上传递给服务器,而会话密钥只有在服务器端用私人密钥才能解密,这样,客户端和服务器端就建立了一个惟一的安全通道。…

IIS漏洞整理大全

 去年下半年关于IIS的漏洞层出不穷,鉴于目前IIS的广泛使用,觉得有必要把收集的资料加以总结一下。 一、介绍   这里介绍的方法主要通过端口80来完成操作,具有很大的威胁性,因为作为网络服务器80端口总要打开的。如果想方便一些,下载一些WWW、CGI扫描器来辅助检查。   而且要知道目标机器运行的是何种服务程序,你可以使用以下命令: telnet 80 GET HEAD / HTTP/1.0 就可以返回一些域名和WEB服务程序版本,如果有些服务器把WEB服务运行在8080,81,8000,8001口,你就TELNET相应的口上。 二、常见漏洞 1、Null.htw   IIS如果运行了Index Server就包含了一个通过Null.htw有关的漏洞,即服务器上不存在此.htw结尾的文件。这个漏洞会导致显示ASP脚本的源代码, global.asa里面包含了用户帐户等敏感信息。如果攻击者提供特殊的URL请求给IIS就可以跳出虚拟目录的限制,进行逻辑分区和ROOT目录的访问。而这个"hit-highlighting"功能在Index Server中没有充分防止各种类型文件的请求,所以导致攻击者访问服务器上的任意文件。Null.htw功能可以从用户输入中获得3个变量:…