木子屋 Dnawo's BLOG

分类:服务器

共 348 篇

两步做好WEB服务器安全

任何计算机与WEB服务器通信都会产生数据流,所以只要严格控制好数据流,那做好WEB服务器安全也就不是一件困难的事了。数据流按方向可分为两类:从外到内的数据流和从内到外的数据流。下边以Windows2003操作系统为例,我们来看下怎么加以控制。 1.控制从外到内的数据流 从外到内,也就是其他计算机向WEB服务器发起的请求,WEB服务器若能响应,一般都是因为某个服务在运行,所以常常看资料说要关闭这个服务,关闭那个服务,其实如果能关闭服务所监听的那个端口,那即使服务在运行,其他计算机也是连不上来的。使用TCP/IP筛选可以非常方便的打开和关闭计算机端口,下边我们看下怎么使用: ①.打开"本地连接"属性,双击"Internet 协议(TCP/IP)":…

IIS的ISAPI接口简介

ISAPI(Internet Server Application Programming Interface)作为一种可用来替代CGI的方法,是由微软和Process软件公司联合提出的Web服务器上的API标准。ISAPI与Web服务器结合紧密,功能强大,能够获得大量的信息,因此利用ISAPI可以开发出灵活高效的Web服务器增强程序。由于ISAPI程序与Web服务器的关系,使得ISAPI接口在安全方面有一定的研究价值。本文主要讨论ISAPI在IIS和VC++ 6.0中的实现。 一、ISAPI接口和CGI接口的不同 ISAPI程序和CGI程序完成类似的功能,但是实现方法不同。 1、ISAPI程序以DLL形式被Web服务器加载到自己的进程空间中,因此和服务器共用同一个地址空间,且在没有客户请求时可以将其从内存中卸载;而对客户端发来的每个对CGI程序的请求则需要服务器为它单独启动一个进程,这需要耗费大量的时间和内存。当并发的请求数目很大时,使用CGI在效率上不如ISAPI。…

Windows7下IIS7.5站点静态内容打不开解决方法

在IIS7.5新建一个ASP站点,asp页面能打开,但布局全乱了,感觉是css、js文件均没有加载。打开一个txt文件测试,浏览器显示空白的,查看源代码也是空白的!再单独访问css、js等文件,也是一样空白!百度后得知是IIS有些功能没安装的缘故。 解决方法:在控制面板中打开"打开或关闭Windows功能",依次展开"Internet 信息服务→万维网服务→常见HTTP功能",钩选"静态内容",确定后待安装结束即可: 再访问下站点,都正常了。

HTTP请求和响应格式

HTTP请求格式 语法: GET请求: 说明:空行是用于分割请求头和请求主体,即使不存在请求主体,它也是必须的! POST请求: 说明:使用POST时,Content-Length和Content-Type是必须的,Content-Length不准确会导致服务器端获取不到完整的内容,缺少Content-Type会导致服务器端使用Request.Form获取不到值。 HTTP响应格式 语法: 响应格式:

设置IIS7显示ASP详细错误信息

当ASP页面出错时,IIS7默认是不给客户端发送详细错误信息的,都是显示: An error occurred on the server when processing the URL. Please contact the system administrator. If you are the system administrator please click here to find out more about this error. 设置IIS7显示ASP详细错误信息 左键单击站点,在功能视图中双击ASP图标: 展开"调试属性",把"将错误发送到浏览器"设置为True即可:

讨论虚拟主机FTP服务器(Serv-U)配置

使用虚拟主机的朋友在FTP连接成功后都会看到类似的文件夹: 今天我们来讨论下用Serv-U6.4.0.2是怎么实现的,最简单的方法,假设有如下文件夹结构: E:\Webs\mzwu.com\wwwroot E:\Webs\mzwu.com\databases E:\Webs\mzwu.com\logfiles\W3SVC10827 那么只要将用户主目录设置为E:\Webs\mzwu.com,目录访问设置为E:\Webs\mzwu.com就可以了。 实际上,由于iis日志增长很快,频繁的进行磁盘读写,我们会将站点和iis日志放在不同的分区中,就有了如下文件夹结构: E:\Webs\mzwu.com\wwwroot…

Serv-U6.4.0.2虚拟路径设置注意事项

磁盘中有如下文件夹结构: E:\a E:\a\b E:\a\c F:\e 测试一 将F:\e映射到E:\a,设置用户主目录E:\a,目录访问E:\a和F:\e,用户连接后可看到b,c,e三个文件夹; 测试二 在测试一基础上将目录访问改为E:\a\b、E:\a\c和F:\e,用户连接后将只能看到b,c两个文件夹,看不到e了。 结论:必须将物理路径映射到用户目录访问列表下的某个路径中(并非总是主目录),用户连接后才能正常访问。

深入理解Serv-U主目录和目录访问

1.用户可以访问的文件(夹)都必须是在主目录下 可以测试,在目录访问中添加一个主目录之外的路径,用户连接成功后是看不到该文件夹的! 2.用户可以访问的文件(夹)都必须是在目录访问列表中 用户可以访问的文件(夹)都必须是在主目录下,但不是主目录中的文件(夹)用户都可以访问的。主目录只是定了一个大的范围,更具体的范围则是目录访问的路径列表,从这点上看,我们将主目录理解为访问权限或许更好。 测试一:主目录E:\a,目录访问为空,用户连接后看不到任何内容; 测试二:主目录E:\a,目录访问E:\a,用户连接后将看到a中的内容; 测试二:主目录E:\a,目录访问E:\a\b和E:\a\c,用户连接后将看到b和c两个文件夹,但看不到E:\a\a.txt;…

安装Microsoft .NET Framework 4.0后站点所有ASPX页面404解决方法

服务器安装Microsoft .NET Framework 4.0后,在IIS站点属性中将ASP.NET版本都设置为4.0,再访问页面发现所有ASPX页面都是404,而访问htm页面却是正常的,后来知道是"Web 服务扩展"中未启用ASP.NET v4.0导致的: 如上图所示,将"ASP.NET v4.0.30319"设置为"允许"就可以了。

Excel导入SQL Server2005失败:产品级别对于组件"xxx"而言不足

今天在将一份Excel数据导入SQL Server2005时总是失败,提示:产品级别对于组件"xxx"而言不足。 百度后知道是MSSQL版本的问题,需要安装sp1,马上去下载安装,再次导入就正常了。 安装了sp1的数据库截图(安装前为9.0.1399): SQL Server2005 sp1下载:点击下载