木子屋 Dnawo's BLOG

分类:服务器

共 348 篇

SQL2005出错:CryptUnprotectData: Win32 错误:-2146893813

如上图所示,在我的SQL Server2005企业管理器中注册了几个服务器,但这几天发现,除了本机服务器(zyq-f7860ae5cd1),其他服务器均不能连接了,一连接就出错,提示:CryptUnprotectData: Win32 错误:-2146893813: Google了下,发觉也有人碰到一样的问题,解决方法是将已注册的服务器删除了重新注册下就好了。后来想起来,在出现这问题前,我有修改了操作系统用户密码,很可能就是这个操作引发了该问题。 异常信息 ************** 异常文本 ************** System.Exception: CryptUnprotectData: Win32 错误:-2146893813…

SQL Server数据库开发的二十一条军规

如果你正在负责一个基于SQL Server的项目,或者你刚刚接触SQL Server,你都有可能要面临一些数据库性能的问题,这篇文章会为你提供一些有用的指导(其中大多数也可以用于其它的DBMS)。 在这里,我不打算介绍使用SQL Server的窍门,也不能提供一个包治百病的方案,我所做的是总结一些经验----关于如何形成一个好的设计。这些经验来自我过去几年中经受的教训,一直来,我看到许多同样的设计错误被一次又一次的重复。 一、了解你用的工具 不要轻视这一点,这是我在这篇文章中讲述的最关键的一条。也许你也看到有很多的SQL Server程序员没有掌握全部的T-SQL命令和SQL Server提供的那些有用的工具。…

T-SQL同一列多行数据合并成一行

上面是课程表结构及数据,下边我们想看下总共有多少门课程,显示格式"课程1,课程2,...",脚本如下: 在行转列中的应用 增加学生表及数据: 查询: 结果: 学生 语文 数学 英语 李四 80 90 100 张三 50 60 70 参考文章 ·SQL语句定义动态列头:http://www.cnblogs.com/ajunsoft/archive/2009/03/30/1425238.html

百万数据查询优化技巧三十则

1.对查询进行优化,应尽量避免全表扫描,首先应考虑在 where 及 order by 涉及的列上建立索引。 2.应尽量避免在 where 子句中对字段进行 null 值判断,否则将导致引擎放弃使用索引而进行全表扫描,如: select id from t where num is null 可以在num上设置默认值0,确保表中num列没有null值,然后这样查询: select id from t where num=0 3.应尽量避免在 where 子句中使用!=或操作符,否则将引擎放弃使用索引而进行全表扫描。 4.应尽量避免在 where 子句中使用 or 来连接条件,否则将导致引擎放弃使用索引而进行全表扫描,如:…

数据库设计规范化的五个要求

通常情况下,可以从两个方面来判断数据库是否设计的比较规范。一是看看是否拥有大量的窄表,二是宽表的数量是否足够的少。若符合这两个条件,则可以说明这个数据库的规范化水平还是比较高的。当然这是两个泛泛而谈的指标。为了达到数据库设计规范化的要求,一般来说,需要符合以下五个要求。 要求一:表中应该避免可为空的列。 虽然表中允许空列,但是,空字段是一种比较特殊的数据类型。数据库在处理的时候,需要进行特殊的处理。如此的话,就会增加数据库处理记录的复杂性。当表中有比较多的空字段时,在同等条件下,数据库处理的性能会降低许多。 所以,虽然在数据库表设计的时候,允许表中具有空字段,但是,我们应该尽量避免。若确实需要的话,我们可以通过一些折中的方式,来处理这些空字段,让其对数据库性能的影响降低到最少。…

SQL Server2000删除日志释放磁盘空间

在SQL Server2000中要删除日志释放磁盘空间得分两步进行: ·执行backup log语句来删除不活动日志,但此时磁盘空间并未释放; ·收缩数据库释放未使用的磁盘空间; 下边详细说明: ①.执行backup log语句删除不活动日志 执行sql语句:backup log Northwind with no_log,不活动日志将被删除,下图为sql语句执行前后数据库大小: 但在资源管理器中查看,你会发现剩余的磁盘空间并没有多出来,原因是日志删除了,但占用的空间未被释放,所以得再收缩下数据库来释放磁盘空间。 说明:这个步骤也有人是执行"dump transaction Northwind with no_log",但SQL Server2000帮助文件中说dump transaction和backup log是同义的,保险起见这两句可都执行一下。…

使用hosts搭建本地域名解析系统

先前有写过一篇类似的文章《使用DNS+IIS在本地创建域名和站点》,它是通过在本地安装DNS服务器来实现域名解析,今天我们使用hosts来实现一样的功能。 ①.在IIS中给站点添加主机头,如hao123.com: ②.修改hosts文件(C:\WINDOWS\system32\drivers\etc\hosts,win2003)如下: ③.在IE中访问hao123.com: hao123.com域名现在是你的了,呵呵。