SQL Server备份还原和分离附加数据库SQL
1.SQL Server备份还原数据库 ①.备份数据库 ②.还原数据库 若是还原到不同名的库,则用: 2.SQL Server分离附加数据库 ①.分离数据库 ②.附加数据库 补充说明 .上边所有操作均应在master库中执行(use master); .killconnection存储过程创建于master库,用于删除指定数据库连接:
1.SQL Server备份还原数据库 ①.备份数据库 ②.还原数据库 若是还原到不同名的库,则用: 2.SQL Server分离附加数据库 ①.分离数据库 ②.附加数据库 补充说明 .上边所有操作均应在master库中执行(use master); .killconnection存储过程创建于master库,用于删除指定数据库连接:
服务器角色 服务器功能
第一步:新建数据收集器集 第二步:新建数据收集器 开始数据收集:
运行perfmon.msc打开性能监视器,添加计数器Web Service→Current Connections,选择要监视的网站:
有一台SQL Server 2008 R2数据库服务器,内存经常占用85%左右,查看进程发现sqlserver.exe使用了4G多内存。有一天服务器重启,业务跑起来后,观察sqlserver.exe内存使用一直在几百M,随后几天持续观察,发现内存使用逐渐升高,这说明SQL Server 2008 R2运行越久,占用内存会越来越大。 有了上边的分析结果,解决方法就简单了,定期重启下SQL Server 2008 R2数据库服务即可,使用任务计划定期执行下边批处理:
有如下两张表: 插入一些测试数据: 然后尝试删除Petson表的记录: 结果不能删除,错误信息如下: 消息 547,级别 16,状态 0,第 1 行 Delete 语句与 REFERENCE 约束"FK_Pet_Person"冲突。该冲突发生于数据库"test",表"dbo.Pet", column 'Pid'。 若确实要删除数据,并且要求相关联的数据也一起删除,只需在数据库外键关系中将更新/删除规则设置为级联即可:
将数据从平面文件源(txt)导入到SQL Server 2008 R2时失败,错误原因是无法在只读列“Id”中插入数据: 解决方法 回到选择源表和源视图界面,打开编辑映射,钩选"启用标识插入",这样即可导入:
在SVN项目根目录空白处点击右键,TortoiseSVN子菜单有一个Relocate,选择它,然后输入新的SVN服务器IP地址即可更改。 说明:一定要在SVN项目根目录点击右键,否则TortoiseSVN子菜单中不会有Relocate。
下午准备将服务器数据导一份到本地,连上服务器找数据库备份文件发现最后一次备份是7月1日,竟然十几天没生成新备份,查看作业历史记录,错误信息如下: 该作业失败。 无法确定所有者 WIN-3TH1KNIT12D\Administrator (拥有作业 Database_Backup.step1)是否有服务器访问权限 (原因: 无法获取有关 Windows NT 组/用户 'WIN-3TH1KNIT12D\Administrator' 的信息,错误代码 0x534。 (错误 15404)). 这应是上次重命名系统管理员帐户导致的,尝试重新选择作业所有者和重建作业,都不好用,最终将所有者更改为NT AUTHORITY\SYSTEM,作业成功执行。…
要知道服务器有没有重启,看系统启动时间即可,下边介绍三种方法查看服务器启动时间。 1.systeiminfo命令 2.本地连接状态 3.Windows任务管理器 说明:Windows Server 2003的任务管理器没有显示开机时间,Windows Server 2008才有。